Patmos - Phoenix Datacenter Network Accessibility – Incident details

All systems operational

Phoenix Datacenter Network Accessibility

Resolved
Major outage
Started 7 months agoLasted 5 days
Updates
  • Resolved
    Resolved

    Root Cause Analysis
    On 9/25/25 at 4:50 MST, clients relying on internal DNS in our Phoenix data center experienced connectivity loss for approximately 90 minutes. The outage was caused by a switch reload that did not retain firewall connectivity settings. Once the settings were restored, full connectivity was re-established. The firewall configuration has now been saved to prevent recurrence during future switch reloads.

  • Monitoring
    Monitoring

    The network is now fully operational, and we continue to closely monitor its performance. A detailed root cause analysis will be shared once it is complete. Please refer to this page for any further updates.

  • Investigating
    Investigating

    We are investigating network connectivity issues in our Phoenix datacenter. Devices hosted in Phoenix are currently unavailable for some customers.

    Our network team is actively working to identify and resolve the issue.

    Updates will be provided as developments occur.