Patmos - Power Outage Notice – Incident details

All systems operational

Power Outage Notice

Resolved
Partial outage
Started 5 months agoLasted about 8 hours

Affected

Phoenix

Partial outage from 3:23 PM to 3:31 PM, Operational from 3:31 PM to 11:18 PM

Updates
  • Resolved
    Resolved

    Power has remained stable throughout the day with no further incidents and services have been restored to impacted customers hours ago.

    Our teams are continuing to work with the vendors responsible for maintaining our power delivery protection systems to further investigate that caused the incident today. They will be assessing the health of the power delivery protection systems that support our customers and applying any repairs as needed.

    We appreciate your patience and understanding in this matter.

  • Monitoring
    Monitoring

    We are glad to announce that power has been restored to the impacted sections of our data center. We are in the process of verifying proper recovery of any impacted systems.

    We will continue to closely monitor the situation to ensure stability. Thank you for your patience and understanding during the outage. If you encounter further issues, please contact our support team. 

  • Identified
    Identified

    We're currently experiencing an isolated power outage. Our team is aware of the situation and is diligently investigating the root cause.  

     

    We understand the inconvenience this may cause and assure you that we're working urgently to address the issue. Your patience and cooperation are greatly appreciated. Stay tuned for further updates. Thank you.