Patmos - Isolated Power Outage Notice – Incident details

All systems operational

Isolated Power Outage Notice

Resolved
Partial outage
Started about 1 month agoLasted about 19 hours

Affected

Kansas City

Partial outage from 11:32 AM to 1:40 PM, Operational from 1:40 PM to 6:16 AM

Updates
  • Resolved
    Resolved

    We are glad to announce that power has been fully restored to our data center. Our operations are back online and running smoothly.  

     

    We will continue to closely monitor the situation to ensure stability. Thank you for your patience and understanding during the outage. If you encounter further issues, please contact our support team. 

  • Monitoring
    Monitoring

    Our facilities continue to run on backup/generator power. We are at full fuel capacity which will allow us to maintain operations throughout the repair efforts upstream with the commercial power provider. Cloud, backup, disaster recovery service, and colocation environments have not been impacted. A small portion of our dedicated server clients are impacted and our team is working to restore services to the zone.

    We will provide another update as we have more details and will confirm when all systems are fully operational.

  • Investigating
    Investigating

    We're currently experiencing an isolated power outage due to severe storms the Kansas and Missouri regions.

    On Wednesday night strong storms with reported wind speeds as high as 80 mph rolled through Kansas and into Missouri causing widespread outages. The Salina, Topeka, Lawrence, and Kansas City metro areas had significant damage. While our facility has no physical damage, we first saw commercial power failures at 10:45PM local time.

    We are currently investigating an issue with our backup power systems for a section of our our racks. Our team is aware of the situation and is diligently investigating the root cause.

    We understand the inconvenience this may cause and assure you that we're working urgently to address the issue. Your patience and cooperation are greatly appreciated. Stay tuned for further updates. Thank you.